This page gives an overview of the main methods for drawing and editing contours in RoboFont.

Drawing contours

Use the Bezier Tool to draw contours.

Editing contours

Once you have placed contours with the Bezier Tool, you can use the Editing Tool to move points and fix handles.

Use the Scaling Edit Tool to edit contours and maintain curve tension by scaling the handles – this is specially useful when modifying the weight of a glyph.

Copying and pasting

You can copy-paste with keyboard shortcuts or the application menu (Edit > Copy, Edit > Paste). The pasted item will be placed in the same location as the source.

Cutting and slicing

Use the Slice Tool to add points or divide contours.

Measuring

Use the Measurement Tool to measure distances between contours. You can place multiple measurements while pressing the ⌥ alt modifier.

Guidelines can also show measurements. Just create a guideline and double click on the guideline to show the guideline attributes modal.

Checking contour quality

We have an entire article dealing with Checking contour quality. “Check” 😅 it out!

Removing (or not removing) overlaps

To remove overlaps in the selected contours, click on the Remove Overlap button in the toolbar. If no contour is selected, all contours are used.

Adding overlaps

You can add overlaps by breaking the contour and adding the needed segments. Copy the original outline to the background as a trace.

Or, you could use the Add Overlaps extension.

Aligning

Use the Editing Tool’s cross-hair cursor to align points while moving a selection.

Turn on point coordinates in the Display Options menu, and use the keyboard to nudge contours to matching x/y position.

Use guidelines to snap the current selection into position.

The Pop Up Tools extension provides a dialog to align selected shapes in the current glyph, similar to align functions vector drawing apps.

Transforming

Use the Transform mode to transform the selected glyph objects interactively. You can scale:

or rotate (hold the ⌥ alt key):

Use the transform Inspector for more options such as applying combining transformations, transforming several glyphs at once, etc.

The Pop Up Tools extension also offers options for transforming the current glyph.

Path operations

RoboFont supports boolean operations (addition, difference, intersection, xor) on outlines through the booleanOperations module. You can apply the boolean operations in the glyph editor using the Pop Up Tools extension (as in the video), or the Path Operator extension

Drawing geometric shapes

Turn on the grid in the Display Options menu. Set the grid size in the Glyph View Preferences.

Digitising drawings

To use an existing drawing as a base for your contours, import an Image into the background of a glyph.

Use the Tracer extension to trace images automatically.

Expanding strokes

In RoboFont you can easily a stroke to a skeleton by using the Outliner extension

Last edited on 15/07/2021