This page gives an overview of the RoboFont user interface.

When you open RoboFont, no window will appear – just the standard macOS Application Menu at the top of the main screen, with quick access to all the main windows and commands.

Font Overview

The main window in RoboFont is the Font Overview. It appears when a new font is created (File > New or ⌘ N), or when an existing font is opened (File > Open or ⌘ O).

Font Overview window

The Font Overview shows all glyphs in a font, and allows you to do many things with them. Double-clicking a glyph cell opens the Glyph Editor to edit the glyph.

Attached to the Font Overview are several specialized panels and sheets to edit different kinds of font data (font info, groups, kerning, features) or do something to the glyph set (search, sort, collect and add glyphs).

Glyph Editor

The Glyph Editor is where the contours and other kinds of glyph-level data (width and margins, anchors, components, layers, guides, images) can be edited.

The Glyph Editor’s top bar offers interactive tools to manipulate points and contours, to draw new contours, to measure distances and to cut contours. Several other editing tools are available as extensions.

Editing Tool, Pen Tool, Slice Tool, Measuring Tool

The Glyph Editor supports zooming in/out and allows you to navigate through all layers in the glyph. The Display menu at the bottom left can be used to show/hide different kinds of glyph data.

Inspector

The Inspector (Window > Inspector or ⌘ I) provides additional tools to visualize and edit data in the current glyph.

Space Center

The Space Center is a dedicated window for previewing small strings of text and editing glyph metrics.

The Space Center offers special tools to aid with spacing, such as the beam to measure margins at a given horizontal cross-section, or the xHeight cut display mode for better visualization of countershapes. Several other display options are available from the menu at the top right.

The Space Matrix at the bottom supports numerical values and also references and calculations with other glyphs.

Single Font Window

RoboFont uses the Multi Window mode by default, with Font Overview, in which Glyph Editor, Space Center and Inspector as separate windows. This mode allows you to move the windows freely across multiple screens, and open multiple Glyph Editors or Space Centers for the same font.

Multi Window mode

RoboFont also offers a Single Window mode in which these windows are united as sections of a single window. This compact mode is useful when working with a single monitor and/or a small screen.

Single Window mode

Preferences

The window mode and lots of other options can be set in the Preferences Window. Additional settings are accessible with the Preferences Editor.

Scripting

RoboFont’s main scripting environment is the Scripting Window, which allows you write and run Python code and navigate through a folder with scripts. There’s also an Output Window to catch print statements and tracebacks from scripts which are not running in the Scripting Window.

Scripting Window

A Package Installer is also available to install external packages in RoboFont using pipA package installer for Python. It can be used to install packages from the Python Package Index (PyPI) and other indexes.

Package Installer

Other windows

Other RoboFont windows not mentioned above:

About Window
show app credits and version info
License Window
display and validate the user’s license file
External Changes window
a modal dialog to selectively integrate external changes to UFOs which are currently open in RoboFont
Extension Builder
tool for creating your own extension packages
Last edited on 15/07/2021